
Further Flash CS5 Discussion 
 
 
Audience and Project Requirements 
 
Identify the purpose, audience, and audience needs for rich media 
content 
 
Before you start any rich media project, a little analysis into your client and 
target audience needs will determine the project’s objectives. These objectives 
are essential for shaping the right design, finding appropriate solutions, and 
keeping the project on track down the line. Be sure to document your findings 
and have them accessible to anyone working on the project because sometimes 
the most obvious and important objectives are most easily overlooked in hustle 
of the project pipeline. You should discuss the following questions with your 
client: 
 

1. What is the client’s purpose of the project? Evaluate the client’s 
goals for the project to see how rich interactive content can best serve 
their purposes. Will the content be educational, entertaining or 
informational? What kinds of media formats do they wish to include? What 
functionality will be needed to accomplish their desired outcomes? What 
level of interactivity do they want to offer their users?  
 

2. Who is the target audience? Defining which demographics make up 
the target audience is important for determining how the rich media 
content should be communicated. Key demographics often include but are 
not limited to age group, gender, computer literacy, education, wealth 
bracket and geographical location. The demographics’ relevance will also 
vary from project to project. 
 

3. What are the audience’s needs? Imagine yourself in your 
audience’s shoes: what are their expectations and how can you best 
deliver that experience to them? Factors such as usability, level of 
engagement, accessibility, user’s time and what technology the audience 
will be using are all examples of how their needs will have to be 
addressed to shape the best experience for them. 

 
Identify rich media content that is relevant to the purpose of the media 
in which it will be used 
 
Having a clear idea of which platform or the types of devices your content will be 
delivered across will have a major impact on the design and development phases 
of the project. You’ve probably noticed how mobile apps have such specific 



functionality, since their screen size is so small they limit their functionality to 
make it easier to navigate. Based on whether your project is a website, desktop 
application, mobile/tablet app or kiosk, the content will have to be organized and 
delivered differently. Examples of the types of considerations you’ll encounter 
are screen resolution, touch screen versus mouse interactivity, Internet 
bandwidth, Operating System, simple versus complex navigation/functionality, 
etc.  
 
 
Identify criteria for determining whether content is relevant to 
the purpose. 
 
It’s tempting when working with rich media content to pull out all the tricks to 
impress and engage your audience. However engaging your audience is more 
dependent on not wasting their time or distracting them with too much with 
superfluous information or bells and whistles. To accomplish this, evaluate all 
content to make sure it has meaningful value to the target audience and that it 
is easy for them to understand. Better to keep things simple, short and to the 
point rather than overwhelm them, possibly confuse them and lose their interest 
all together.  
 
Accessible Rich Media Content 
 
Understand options for producing accessible rich media content 
 
Accessibility in the target audience 
 
When creating rich media content it is crucial to consider all types of people who 
will make up the target audience. Many people with visual, auditory, mobility and 
other disabilities have difficulties accessing various aspects of content and use 
assistive technology to aid them in navigating the websites and applications. By 
making content accessible you are helping your client reach more people and 
ensures that no member of the target audience has to endure additional 
frustration or is left out of the experience. 
 
Screen readers and the Accessibility Panel  
 
Flash Professional has made it easier for you to create accessible rich media 
content. By using the Accessibility Panel (found under the Window > Other 
Panels) you can make content readily available for screen readers to interpret for 
people with visual impairment. Screen reader software such as JAWS, Windows-
Eye and Yahoo Asteroid Toolkit read the content on web pages out loud for a 
vision impaired user and that person can also use keyboard shortcuts and the 
“tab” key to browse screen information more quickly and selectively.   
 
When interpreting a Flash movie the screen reader will read any text in the SWF 
and will look for alternative text to read on buttons, images and animations. 
Every object can be given a Name, a Description and a Tab Index number in the 
Accessibility Panel, which a screen reader would read off in that assigned order 



according to the object’s Tab Index. This is useful for all buttons, images and 
animations that convey important meaning to a user. For objects that wouldn’t 
have relevant meaning to someone using assistive technology, these objects can 
be hidden from screen readers by unchecking the “Make object accessible” 
checkbox on the Accessibility Panel.  
 
Handling animations and complex rich media 
 
For animations you should assess the content to determine how they should be 
presented to screen readers. Animations trick screen readers into interpreting 
any movement as a new page being displayed so it starts reading the content 
over again from the top. You can imagine how frustrating this could be for 
someone trying to use a screen reader, so you should either hide the animation 
completely or hide just the movement which allows you to still include a text 
equivalent for the animation by checking the “Make object accessible” checkbox 
and unchecking “Make child objects accessible”. For animations that could add to 
the experience of someone using a screen reader simply allowing for some 
control over the playback could allow them to experience the content more 
interactively. For other objects that have dynamic states such as toggle buttons 
you should update the screen reader with the updated functionality of the 
button. As the complexity of the Flash movie increases it becomes harder for 
people using screen readers to navigate, so a good rule of thumb is to include a 
brief summary of information that can be accessed on each page and create 
good descriptions for navigation buttons. 
 
Other accessibility considerations 
 
There are some easy steps you can take to making your content more accessible 
early on in the design stage.  Consider different types of color vision deficiency 
when selecting your color scheme and never rely on color alone to express 
information. Also many elderly people have trouble reading small font sizes so 
keeping the fonts at a more legible size, or having options to make the text 
appear larger is a good idea. For the visually impaired you should always allow 
for user control of audio and video, building on this you can increase accessibility 
by giving keyboard shortcuts to playback controls. For people who are deaf or 
hard of hearing you can easily add closed captioning at cue points in your Flash 
Video or provide the text equivalent of audio clips.  
 
Through the development process and certainly before your project launches you 
should validate for accessibility by navigating the content with different screen 
readers and by having people with diverse impairments perform usability tests. 
By taking this measure you ensure that your efforts result in rich media content 
that is thoroughly accessible. 
 

Copyrights 
 
Demonstrate knowledge of standard copyright rules (related 
terms, obtaining permission, and citing copyrighted material)  
 
First review the following terms: 



 
Intellectual Property – can be any original work in the form of a design, text, 
photo, video, sound, logo, name or innovation that is used commercially or as a 
form of expression.  
 
Copyrighted – the copyright law protects the ownership of intellectual property 
once it has been created in a fixed medium with or without applying for a federal 
copyright. In order to reuse or reproduce copyrighted property that is not yours 
written permission must be obtained from the creator or owner. Many cases of 
obtaining permission will also include paying royalties. Whenever you see 
“copyright” or the © symbol, author name and/or published date that work falls 
under copyright protection. It is safe to assume any work you see, hear or read 
is copyrighted unless it comes with a statement that that you may reproduce it 
without permission from the author/owner. 
 
Fair Use Doctrine – this creates a loophole in the copyright law whereby 
copyrighted material can be reused in part as long as it falls under the guidelines 
of “fair use”. These “fair use” guidelines loosely stand to help the flow of 
information to the public as long as the usage is not at too great of a conflict to 
the original work. Usually educational purposes fall under ”fair use”. 
 
Derivative Work - is a new product that includes an aspect of a previously 
copyrighted work. 
 
Citing online copyrighted material: 
When reusing a copyrighted work under the Fair Use Doctrine you should always 
cite the original material. For video, audio, text, images and websites found 
online you should always cite the creator(s), the title, the creation date, the URL 
and a brief description may also be necessary.  
 

Project Management 
 
Understand project management tasks and responsibilities 
 
The Project Plan 
 
The Project Plan provides the framework for creating a strategized process from 
start to finish. It includes the project scope: which details specifications, internal 
due dates, milestones for project deliverables that the client would then approve, 
and final deadlines. Possible deliverables may be sketches, wireframes, mockup 
designs, interaction/animation storyboards, sitemap structure and prototypes. 
The Project Plan details resource allocation, which indicates which tasks go to 
which team members.  
 
Scope creep happens to just about every large-scale project, it is the expanding 
of work beyond the original Project Plan. The effects of scope creep can have a 
devastating impact on everyone’s time and the client’s expectations. Therefore 
the Project Plan should allow for some shifting of internal due dates so that tasks 
are not held up by other tasks taking too long. It is essential to examine the 



project structure and break it down into detailed tasks and evaluate which tasks 
may encounter complications. As always, timely communication between team 
members and with the client is a key factor in the project’s success. 
  
 
The Phases of the Project Plan are: 
 
Analysis and Planning - is the first step where client goals and target audience 
considerations are established and initial project planning begins. 
 
Design - plans start to take visual shape in the form of style guides, color 
schemes, wireframes, graphics and design mockups. 
 
Building/development - prototypes are built that make up the interactivity 
and functionality for the rich media content. Graphics are also integrated. 
 
Testing - quality assurance testing is performed to uncover any bugs, usability 
issues or other possible errors and is reported back to the design/development 
team for revision.  
 
Implementation/Launch – the project is in its final stage, having all bugs 
from testing squashed and with the client’s approval to launch it is ready to “go 
live” and be made available to the public. 
 
Rich Media Design Elements 
 
Benefits of Consistency 
 
With the wide range of creative freedom Flash extends to designers and 
developers, it can be tempting to try to impress a client with a unique approach 
they’ve never seen before. However the most import aspect of an interface is 
that it functions well for the target audience. Design conventions are good 
because they create consistency that users can easily follow based on their past 
experiences. Links that look like buttons, identical navigation across all pages 
and icons that clue the user into the content are a few helpful design 
conventions. Sticking to design conventions and keeping the end user in mind 
will help you to avoid re-inventing the wheel. 
 
Web-Safe Colors 
 
With the availability of so many different computers and browsers, both old and 
new, there can be a wide variance of how designs will display on each screen. To 
tame the effects of this, a number of web-safe colors were adopted and display 
more consistently regardless of the computer setup. In Flash you have the 
freedom to pick any color but for important design elements that you want to 
display reliably you should use web-safe colors. 
 
Identify criteria for deciding if content should be implemented by using 
rich media  
 



Flash’s powerful range of animation and development tools combined with some 
creative juice can manifest rich media solutions for the obstacles of keeping the 
target audience’s interest engaged. Creating informative animation and 
transitions can illustrate information, progression and visual hierarchy. Audio and 
video files can be easily implemented to display with consistent skins and 
controls across browsers and Operating Systems. Screen real estate can be 
saved from content overload by organizing navigation into dropdown menus or 
layering information into one dynamic area of the screen.  
 
Benefits of authoring FLV files for Adobe AIR 
 
Authoring FLV files for Adobe AIR saves you the hassle of having to work with 
multiple video file formats for various computer platforms. 
  
Benefits of including metadata into SWFs 
 
Adding metadata to SWFs helps search engines target your website pages and 
can help you track where and how your website/application is used. 
 
Principles of Graphic Design 
 
To help give your designs strong visual appeal and make them more effective in 
communicating to your audience, there are some basic design guidelines and 
principles you can follow. A key aspect in effective communication design is 
information chunking, where you break up your content into more manageable 
pieces of information and organize them in a way that makes intuitive sense to 
the viewer.  
 
Spacing these elements in close proximity gives them visual unity, which in turn 
lets your audience know they are related. Keeping ample space between 
elements, as well as adding lines between them helps to create a sense of 
separateness.  
 
Most people only skim the content on a page until they’ve found what they’re 
looking for. There are a few ways you can direct your audience’s attention and 
put emphasis on certain elements that you wish for them to see first. Eye 
tracking studies have shown that people’s attention go from big to small, dark to 
light and saturated to de-saturated colors. Content that moves such as 
advertising banners draw attention, so use movement wisely in your design. 
 
Site-wide consistency is a proven usability tactic you can see in almost all 
effective websites. All of the webpages have the header, navigation and other 
design elements positioned identically throughout the website, while only the 
page content changes. The one page that can have some variation to this rule is 
the landing page or the home page, as it is first page your audience will see and 
can be given a special visual treatment appearance. 
 
Symmetry and balance 
 



There are various ways you can lay out content to affect the balance on screen. 
Symmetrical layouts are frequently used in website design, because aligning 
content symmetrically across a plane will give your design an eye pleasing 
balance. Horizontal symmetry is the most popular in website design because it is 
the symmetry we relate to most as we see it in our own bodies, as we are 
identical on both sides. Vertical symmetry has it’s place in website design too 
where the top of the page is balanced by a mirroring of the bottom. Of course, 
the mirroring is rarely identical but you can still play with symmetrical effects to 
create a sense of balance. Some less standard symmetrical layouts you might 
experiment with is radial symmetry, which mirrors out from the center and 
diagonal symmetry, which mirrors across a diagonal plane. Asymmetrical layouts 
can also be used to create an uneven look, which can be interesting to view as 
well.  
 
See examples of the types of symmetry below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
The Rule of Thirds is a simplification of the Golden Ratio or Divine Proportion 
used by artists of the Renaissance. With the rule of thirds you can achieve a 
visually appealing balance that mimics the organic nature of the Golden Ratio by 
dividing your layout into three equal parts. This “dividing by three” process can 
be repeated until you have a grid to work with and then you can place your 
content to fill the squares of the grid.  
 
Common design mistakes 
 
Probably one of the most common design mistakes is trying to do too much, 
resulting in overdoing the design. When making design decisions it is best to 
remember that less is more and to keep it simple. A good rule to keep in mind is 
“Perfection is achieved not when there is nothing more to add, but rather when 
there is nothing more to take away.” – Antoine de Saint-Exupery. Having too 
much textual content crammed into one page, is like alerting your reader “this is 
probably going to be boring.”  It won’t hurt to break up the content and add 
relevant images to give more substance to the content. On the other hand also 
think about whether the graphics are truly needed, you don’t want a picture’s 
purpose to be just a space filler. The same can be said for using too many colors, 
especially too many vibrant colors which all call for attention at once. Rich media 
content can easily become overwhelming, which is why completely blank areas 
on your page also known as White Space help to create a less overwhelming 
page. (Although White Space doesn’t have to be white.) Websites that don’t 
have site-wide consistency don’t look cohesive across all pages and can become 
confusing for your audience. 
  
Text formatting guidelines  
 
Finding the right font to use with your design can be quite a process so a little 
background knowledge about text formatting can help you narrow down your 
search. The best fonts to use in rich media content are Screen Fonts, which are 
fonts specifically designed to display well on computer screens. Since computer 
screens have less resolution than printers it is better to go with a simpler font 
that is easier for the screen to display, especially for the smaller text that makes 
up the body of your content.  Serif fonts like Times New Roman are commonly 



used for print and are more decorative than sans-serif fonts like Arial or 
Verdana, which are better Screen Fonts. (Sans means “without” in French.) It is 
important to use appropriate font sizes for readability, which should be 
determined by the target audience, different monitor displays, legibility of the 
font and other restrictions of the project. Based on the average factors a safe 
minimal font size that is legible is 12pt. It is also imperative to go with font 
colors that contrast well against the background color but do not clash against it. 
Beware of bad font color decisions like bright blue text on a black background 
(which contrasts so much it appears to move when you read it) or orange text 
on a yellow background (which probably won’t be enough contrast on most 
monitors.) 
 
Aside from bolding, italicizing or underlining text there are other formatting 
options to improve the reading experience and make text more flexible within its 
allotted space.  Adjusting the space between characters is called kerning and line 
spacing can also be adjusted to give more or less room between lines of text. 
Margins and indenting can be used to move text in from a graphic or in from the 
alignment of other paragraphs of text. All of these options can improve the 
organization of the content and improve the reading experience. 
 
Some Flash specific settings that are important for the legibility of your 
text are the anti-alias options: 
 
Anti-alias for readability - is best for making small static text legible because 
it renders the fonts smoother.  
 
Anti-alias for animation - will create a smoother animation because it ignores 
kerning and spacing formatting.  
 
Custom Anti-alias - let’s you modify the font’s thickness and sharpness.  
 
Bitmap text - no Anti-alias - will create a smaller SWF file by not applying any 
smoothing to the font’s outline. 
 
Use device fonts - will create a smaller SWF file by using the fonts that are 
available on the end user’s computer. Your font selections will be very limited by 
this option. 
 
You will also want to select the option in the Properties window for a text box to 
be static, dynamic, or input text. The static option is for text which will not 
change throughout the course of the movie. Dynamic text is used for a text box 
that can change through code/user interaction. Input text allows for the user to 
type into the text field which is useful in forms.  
 
Creating Patterns from Symbols 
 
You can achieve some pretty nifty effects with the Spray Brush Tool and the Art 
Deco Tool. With both tools you can set a symbol to be the repeating element; 
the Spray Brush Tool will repeat the symbol in a random effect whereas the Art 
Deco Tool will allow you to create more symmetrical patterns. With the Art Deco 



Tool if you choose the Symmetry Brush as the Drawing Effect (in the Properties 
Window) Flash will create the corresponding symmetry across a line or point 
based on where you brush in instances of the symbol. With Grid Fill as the 
Drawing Effect you can set up a symbol to be tiled across the Stage. 
 
 
Using storyboards to produce rich media elements 
 
Storyboards are useful for drafting a plan for your Flash animations and even for 
planning how a complex interaction will work. Just like the storyboards used for 
animated shows and movies you create a sequence of drawings of the key 
moments and each drawing has text below describing what’s happening. 
Important things to include in a rich media storyboard are any times human 
interactions take place, any changes in button states, transitions, movements, 
sounds, where links go and the layout of the elements. Storyboards are a helpful 
tool because they make you visualize, think through and plan out the details so 
problems can be worked out earlier in the process when it’s easy to make 
changes. They also help to explain the animation or interaction to other team 
members, making it easier to collaborate on a project. 
 
Understanding the Adobe Flash CS5 Interface 
 
The Property Inspector Window 
 
Much of the control you have over your objects on the Stage are editable with 
the Property Inspector Window (under Window > Properties).  It contains all the 
text-formatting options, tween properties, filters options and adding sounds to a 
frame. It also gives you control over editing a shape’s stroke, fill and symbol 
properties such as positioning, size and alpha. 
 
The Timeline Window 
 
The Timeline Window gives you control over your layers, tweens and timing. The 
black dots under the eyeball icon allow you to turn a layer invisible. The black 
dots under the lock icon let you lock a layer so its contents can no longer be 
editable on the Stage. Clicking the frames under the black frame icon allow you 
see just the outline of that layer’s objects on the Stage in a single color that 
matches that layer’s frame color. All of the numbers along the top of the timeline 
represent the frames’ numbers. The Playhead (the red rectangle with the red line 
beneath it) can be dragged along the timeline to preview tweens or just to see 
what’s on a frame. You can control Playback in the timeline from the Control 
drop down menu or you can also press the Enter or the Return key to start your 
animation playing. The icons along the bottom below the frames are your onion 
skinning tools, they allow you to see an animation’s progress by having a 
ghosted preview of each previous frame you’ve included in the onion skinning. 
The previews can also be Onion Skin Outlines, which will just show the object’s 
outlines, which can make it easier to see all of them at once. 
 
 
 



Flash Rulers, Guides and Snapping 
 
Setting up guides and rulers are useful for making sure elements in your design 
align properly. Rulers along the top and left side of the Stage can be made 
visible/invisible by going to View > Rulers. To change the Rulers to Pixels, Inches 
or Centimeters you’ll need to go to Modify > Documents and change the Ruler 
Settings. To create guides you must have the rulers turned on and you can 
either drag out a horizontal guide out from the top ruler or vertical guides can be 
dragged out from the left ruler. You can lock the guides into place, so you don’t 
accidentally misplace them.  
  
Guides are especially useful when you turn on snapping options (under View > 
Snapping). Guide properties can be changed under View > Guides > Edit Guides. 
There you can change their line color to not blend in with the colors in your 
design and you can also adjust the distance of how far away an object can be for 
snapping to occur. 
 
Snap to Guide - will line up the object you have moved on the Stage with the 
guides you have set up. 
 
Snap to Grid - will line up the object you have moved with the Grid if you have 
it visible. 
 
Snap to Pixels – will line up the object you have moved to precise pixels. 
 
Snap to Objects – will line up the edges of the object you have moved to the 
edges of other objects on the Stage. 
 
Snap Align - will line up an object at a preset distance from other objects on the 
Stage. 
 
Creating and editing Motion Paths 
 
After creating a tween you can edit the Motion Path on the stage by dragging the 
tweened MovieClip’s position or by clicking on the MovieClip with the 
Subselection tool and dragging the Bezier control points to reshape the Motion 
Path itself. 
 
Adding Video to Your Movie 
 
The most recommended ways to deploy video in your Flash movie is through 
progressive download or streaming. Streaming is best for when lots of viewers 
will be watching the videos at the same time it allows viewers to watch the video 
as it is still in the progress of downloading. These videos will have to be stored 
on a streaming service such as Flash Media Server.  For progressive download, 
the movie gets linked to externally and then downloads on to the user’s 
computer, gets cached and played. The other method is the Embed FLV in SWF 
and Play in Timeline Option in the Import Video Wizard. This option is not 
recommended unless your video is very small and short (under one minute) and 



does not contain any audio because the video and audio can easily become 
desynchronized.  
 
XFL and XMP File Types 
 
With Flash CS5 comes XFL, the new FLA file format which is a zipped folder of 
XML based files which can be unzipped and expose all the information for your 
movie. This information can be edited, allowing you to make faster updates and 
make global changes to your movie. 
 
XMP (Extensible Metadata Platform) allows you to add extended metadata to 
your FLA files and subsequent publishes. You can edit the metadata information 
like, document title, author, keywords and description by going to File > File 
Info. 
 
Best Practices for Minimizing File Size 
 
Creating the smallest possible movie file size is important for delivering content 
quickly over the Internet. Here are some tips for keeping your file sizes small: 
Use Flash’s drawing API to create the graphics, you’ll be surprised by how 
graphics that were created in Photoshop or Illustrator can be recreated by using 
Flash’s graphic tools and a little out of the box creative thinking. Create symbols 
out of your objects and reuse them. Don’t overcomplicate shape tweens. Save 
images out for the web prior to importing them into Flash. Break apart graphics 
in Flash and link externally to images and videos. 
 
 

Building Rich Media Elements by Using Flash CS5 
 
Which tools can you use to for selection? 
 

     
 
Selection, Subselection, Lasso, Free Transform 
 
Which tools can you use to modify shapes? 
 

      
 
Selection, Eraser, Pen, Paint Bucket, Free Transform 
 
What are some ways you can modifying graphics? 
 
Break Apart - Select the graphic and go to Modify > Break Apart. Breaking 
apart Flash graphics or a bitmap image divides the colors of the graphic into 
sections and is useful for when you would like to edit those color blocks. You can 
modify a broken apart graphic by using the magic wand tool (under the Lasso 
Tool) to select certain areas, use the Eyedropper Tool and Fill Tool to add new 
colors. 



 
Trace Bitmap – Select the graphic and go to Modify > Bitmap > Trace Bitmap. 
Tracing your bitmap can drastically reduce the size of your Flash movie because 
it conjoins the pixels into like-colored vector segments. You can adjust options in 
the Trace Bitmap window such as the Color Threshold which determines how 
closely Flash will try to match the colors. (The smaller the number the closer the 
match.) Decreasing the number of the Minimum area will also create a closer 
match because it will also stay truer to the original pixel sizes. You can also 
change the Corner threshold and curve depending on how tight you would like 
your corners and curves to be.  
 
Swap Bitmap – Modify > Bitmap Swap Bitmap allows you to switch a graphic 
on the Stage with another graphic from the library. 
 
Text Layout Framework (TLF) 
 
By selecting the TLF text option in your Properties window, you’ll have superior 
control over your text content. For starters TLF encompasses over 30 script 
written languages with support for vertical text and right to left text. It has 
additional character controls such as kerning, leading, highlight color, digit case, 
digit width, ligatures, underline superscript and subscript to name a few. It also 
includes more paragraph options including the very useful multi-column text flow 
and text flow across linked containers. Other new paragraph styling options 
include margins, last line justification, indents, paragraph spacing, support for 
tabs, hypertext and baseline shift. There’s also embedded font support and anti-
aliasing for CFF fonts and the ability to style text from an external XML file. 
 
Inverse Kinematics using the Bone Tool 
 
A cool feature that came out with Flash CS4 is inverse kinematics, which creates 
bending effects by calculating how pieces of the whole would move if in the 
physical world. This is useful for character animation and mimicking organic 
movements like arms and legs bending, or making a ribbon appear to blow in the 
wind.  
 
To start you want to apply a bone chain to a symbol, a series of symbols, line, 
shape or brush stroke. You do this by click and dragging a few bones across the 
areas of the element you want to manipulate; this will create an armature layer 
in your timeline. You can then create a tween by creating a keyframe and then 
repositioning the links of the bones. You can add easing effects to your tweens  
and adjust how much spring there is in the movement. By decreasing the 
Strength of the spring you make it more bendable, and by decreasing the 
Dampening of the spring it will spring for a longer duration. 
 
ActionScript Coding Basics 
 
Some basic concepts in Object Oriented Programming: 
 



Variable – variables are where values are stored. In ActionScript 3.0 you must 
declare your variable to announce what kind of value it will store based on 
whether it is going to hold a number, string, Boolean, etc.  
 
Function - Flash has built-in functions and there are also the functions you 
create yourself. Functions are blocks of code that accomplish a purpose and can 
be called multiple times from any other code in the document. 
 
Class – Classes are the templates that define attributes, properties of objects 
and actions of methods. 
 
Object – An object is an instance created from a Class, it is where you will run 
methods and send and receive data. 
 
Method – Methods are functions that have been defined by a Class and give 
action to an Object.  
 
Property – Properties are used all throughout Flash. In MovieClips they are the 
x,y coordinates, width, height and alpha. You can manipulate the properties of 
all sorts of things such as tweens, videos and sounds and you can create your 
own property definitions in Classes. 
 
The simplest of ActionScript functions are stop(), gotoAndPlay() and 
gotoAndStop(). With these you direct the playback within the timeline. If you 
have an animation that you don’t want to loop you insert the stop() code into the 
actions window on the last frame of the animation, which causes the playhead to 
stay paused on that frame. For gotoAndPlay() you can direct the playhead to 
jump to another scene and/or frame and it will continue playing whereas 
gotoAndStop() would go to the other frame and pause there. Other useful 
actions Flash has built in are navigateToURL() and SoundMixer.stopAll().  
navigateToURL() is used to link to the URL specified in the URLRequest object. 
The SoundMixer class contains properties and methods to control sounds in your 
movie, one useful method is the stopAll() method which can be used to pause all 
sounds which are currently playing. All of Flash’s built-in functions help you 
utilize the rich media tools available in Flash and handle events like responding 
to mouse clicks or starting an action after a sound clip finishes playing.  
 
 

Evaluating Rich Media Elements by Using Flash CS5  
 
Spell Check Your Document 
 
Select Text > Check Spelling to start spell checking your document. You can edit 
Flash’s Check Spelling options by clicking Text > Spelling Setup. There you can 
choose from a myriad of options to check certain types of text throughout the 
document such as ActionScript strings, symbol names, current scene only. You 
can also select which dictionary language is used and you can add your own 
words to your personal dictionary. There are also plenty of options to customize 
how Check Spelling works, like ignoring internet/file addresses, ignore first letter 
capped words and finding duplicate words. 



 
 
 
Check your Flash document against your Storyboard 
 
When the pieces of you animation or interaction start to come together you 
should test them against your Storyboard. Have your storyboard handy either on 
screen or printed out. Run your Flash document either in the timeline or you can 
do Control > Test Movie, follow along with your storyboard to make sure all the 
events are running as planned, you can use the Enter or Return button to pause 
the movie if you need more time to follow along or double check.  
 
Usability Testing 
 
You will need: a few test subjects that are representative of your target 
audience, a computer to test on and a plan. 
 
Usability testing does not have to be an expensive or time consuming, but it 
should definitely be done so you can ensure your project will accomplish its 
purpose, which could be anything but confusing, irritating and losing your 
audience. 
 
For your final usability tests it would be nice if you could test out all the possible 
situations your audience may encounter, but this may be improbable with typical 
time and budget restraints. So instead try to cover a variety of tasks that would 
allow a user to navigate your content in different ways. It would be helpful if the 
tasks chosen are based on past usability information gathered throughout the 
lifecycle of the project, although a lot of the time the usability test is an 
afterthought and this is not possible. Sometimes coming up with a scenario is a 
better way to explain a task to a test subject because you give them more 
background information and a more personal purpose to the task.  
 
Conduct the usability test in private with the test subject in a distraction free 
environment. Try to get your test subject to “think out loud” what they are trying 
to do as they accomplish each task. This is important for gathering information 
about their thought process and may be helpful in coming up with better 
solutions.  Avoid asking leading questions that would give away the answer. 
 
Observe which tasks work and which ones fail completely or cause the user 
trouble. Take notes of where they go amiss or get stuck, also record subject’s 
comments and be attentive to cues that they are frustrated, such as their facial 
expressions. Coming up with a good post-usability test interview, which will also 
help in determining if the project’s design and functionality worked. 
 
 


